Home > Software > NI Industrial Controller Device Drivers 19.0

NI Industrial Controller Device Drivers 19.0


4-10-2019, 15:23. Author: mitsumi

NI Industrial Controller Device Drivers 19.0

[b]NI Industrial Controller Device Drivers 19.0 | 2.7 Gb[/b]
The National Instruments team is pleased to announce the availability of Industrial Controller Device Drivers 19.0 wich allows you to configure Industrial Controller devices and control their digital I/O.


[b
NI Industrial Controller Device Drivers 19.0 Readme - June 2019[/b]

The following list describes the new features in NI Industrial Controller Device Drivers 19.0
- Added support for LabVIEW 2019
This release supports the following hardware:
- IC-3120
- IC-3121
- IC-3171
- IC-3172
- IC-3173

[b]NI Industrial Controllers [/b] are high-performance, fanless devices that offer the highest level of processing power and connectivity for automated image processing, data acquisition, and control applications in extreme environments.

Used for communication and synchronization to EtherCAT and Ethernet CompactRIO chassis, EtherCAT motion drives, GigE Vision and USB3 Vision cameras, and other automation equipment. Controllers also have onboard isolated, transistorÔÇÉtransistor logic (TTL), and differential digital I/O. You can use LabVIEW system design software to create, debug, and deploy logic to both the onboard FPGA and the processor. LabVIEW contains over 950 signal processing, analysis, control, and mathematics functions to accelerate development.

Industrial Controller doing analysis on items on a small conveyor

[b]Since 1976, National Instruments [/b] has equipped engineers and scientists with tools that accelerate productivity, innovation and discovery. NI's graphical system design approach to engineering provides an integrated software and hardware platform that speeds the development of any system needing measurement and control. The company's long-term vision and focus on improving society through its technology supports the success of its customers, employees, suppliers and shareholders.

[b]Product: [/b] NI Industrial Controller Device Drivers
[b]Version: [/b] 19.0.0
[b]Supported Architectures: [/b] 32bit / 64bit
[b]Website Home Page :[/b]
http://www.ni.com
[b]Language: [/b] english
[b]System Requirements:[/b] PC *
[b]Supported Operating Systems:[/b] *
[b]Application and Driver Software Support:[/b] *
[b]Size: [/b] 2.7 Gb

[b]The development computer must meet the following requirements to run NI Industrial Controller Device Drivers:[/b]

[b]Processor [/b] Pentium 4 1 GHz or equivalent
[b]Memory [/b] 512 MB RAM
[b]Display [/b] 1,024 x 768 resolution video adapter with a 16-bit display
[b]Free Hard Disk Space [/b] 2.7 GB (Minimum Recommended)
[b]Operating System [/b]

- Windows 10 (32- and 64-bit)
- Windows 8.1 (32- and 64-bit)*
- Windows 7 SP1 (32- and 64-bit)**
- Windows Embedded Standard 7 SP1 (64-bit)**,***
- Windows Server 2012 R2 (64-bit)*
- Windows Server 2008 R2 SP1 (64-bit)**

[b]Note [/b] NI Industrial Controller Device Drivers 16.0 dropped support for Windows Vista, Windows XP, Windows Server 2003, and installations of Windows 7 without any service packs. NI Industrial Controller Device Drivers 16.0 and later will not install or run on an unsupported OS. You cannot deploy or distribute applications that use NI Industrial Controller Device Drivers 16.0 or later to an unsupported OS. Additionally, after installing NI Industrial Controller Device Drivers 16.0 or later, you cannot use any installers built on this computer with any version of LabVIEW, LabWindows/CVI, NI TestStand, or Measurement Studio on an unsupported OS.
[b]Note[/b] Support for Windows 32-bit operating systems may require disabling physical address extension (PAE).

* NI software installs VC2015 Runtime and .NET 4.6.2. Windows 8.1 and Windows Server 2012 R2 require Microsoft updates to support these items.
** NI software is signed with a SHA-256 certificate. Windows 7 SP1, Windows Embedded Standard 7 SP1, and Windows Server 2008 R2 SP1 require Microsoft updates to support SHA-256.
*** Only supported as pre-installed on NI hardware.

[b]NI Application and Driver Software Support[/b]
The bellow lists the NI application and driver software versions, including service packs, supported by the NI Industrial Controller Device Drivers. The installer specifically allows side-by-side installations of NI Industrial Controller Device Drivers for each of the supported versions of LabVIEW, enabling you to use the NI Industrial Controller Device Drivers with multiple versions of LabVIEW. National Instruments recommends that you install LabVIEW, LabVIEW Real-Time, and any other supported development environment before installing NI Industrial Controller Device Drivers.

NI LabVIEW........................................2016, 2017, 2018, 2019
NI LabVIEW Real-Time Module.......................2016, 2017, 2018, 2019
NI LabVIEW FPGA Module............................2016, 2017, 2018, 2019
NI Vision Development Module......................2015 SP1 or later
NI Vision Acquisition Software....................February 2016 or later
NI Vision Builder for Automated Inspection........IC-3120, 3121, and 3173-2015 or later, IC-3171 and 3172-2015 f1 or later
[b]DOWNLOAD[/b]
(Buy premium account for maximum speed and resuming ability)





Go Back